每天学习一点点,成功增加一大步

标签:PKCMS

PHP

php7中对preg_replace内的e不再支持

php7中对preg_replace内的e不再支持
背景 最近想升级 PKCMS 系统,直接用的之前的代码,将系统适配到 PHP7,之前适配的是 PHP 5.3~5.6,然后一顿操作,发现打开后成一片空白,傻眼了,开始从系统底层检查,最后发现是模板引擎中的模板标签语法解析出了问题。这段解析来自 PHPCMS 的底层。 ...

zhanghui 2个月前 (08-04) 140℃